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Company’s Information 
Verify / update company’s information such as contact person, contact number, bank information, 

and company’s statutory number and etc. 

1.1 View Company’s Information 

Company Setup > Control Master (Admin) > Payroll Setup >Tick Expand All to view all information 
[Figure 1-1] 

 

1.2 Amend Company’s Information 

Insert new information > Save [Figure 1-2]  

Reset – clear all existing data 

  

Figure 1-1 

Figure 1-2 



 
 

Policy 
Define pay periods for payroll / cut-off date based on company’s rules. 

2.1.0 Payroll Pay Policy 

2.1.1 Create Payroll Policy 

Payroll > Policy > Payroll Pay Policy > Add [Figure 2-1] 

 

Insert name of Pay Policy > Insert cut-off date & set it as previous month or current month > Save 
[Figure 2-2] 

 

  

Figure 2-1 

Figure 2-2 



 
 

Example: 

Pay Policy name: ALL / STAFF / FOREIGN WORKER [Figure 2-3] 

If DO NOT practice mid-month payroll > tick No Mid-Month Pay (don’t have to put any cut-off date) 

End month cut off: 31st  

Meaning, salary calculation starting from 1st to 31st (final day of the month) 

E.g. May 2020 payroll, salary calculate from 1st May 2020 to 31st May 2020 

Allowance, Deduction, Overtime: Cut Off: 20th, Current Month 

Meaning, Allowance, Deduction and Overtime will be count from 21st of Apr 2020 to 20th May 2020 

 

Once data is Save, screen will be displayed as [Figure 2-4] 

 

If cut-off date for employee Allowance is 20th; Previous Month 

Meaning, Allowance will be calculated from 21st Mar 2020 to 20th Apr 2020 for May 2020 payroll 

 

  

Figure 2-3 

Figure 2-4 



 
 

2.2 Payroll Period Maintenance 

2.2.1 Create Payroll Period  

Payroll > Pay Policy > Pay Period Maintenance > Generate [Figure 2-5] 

 

Select - Year, Month, Pay Policy and Pay Period Type > Generate [Figure 2-6] 

* Month: ALL to ALL means Jan to Dec 

 

* Overwrite current pay period means delete the current pay period and regenerate new pay period 

following the latest pay policy.  

 

Once being generated, screen will display [Figure 2-7] 

  

Figure 2-5 

Figure 2-6 

Figure 2-7 



 
 

2.2.2 Create Ad-Hoc Pay Period 

Click Create > Select Year, Month, Pay Policy, Tick √ Ad-Hoc and set the name of pay period without 
spacing  

> Generate [Figure 2-8] 

 

 

2.2.3 Open/Close Pay Period 

Edit > Select Inactive – OPEN means the pay period is ready to process > Save [Figure 2-9 & Figure 2-
10] Edit > click Open – CLOSED means the pay period is disabled for processing > Save [Figure 2-9 & 
Figure 2-10] 

 

  

Figure 2-8 

Figure 2-9 

Figure 2-10 



 
 

2.2.4 Edit Date of Pay Period 

Payroll > Pay Policy > Pay Period Maintenance > Edit > Change the Date > Save 

* NOTE: Previous month End Date and current month Start Date must be a continuous date  

 OR 

 Current month End Date and next month Start Date must be a continuous date 

 

Example: 

Change Overtime cut-off for February 2020 

Original cut-off : 2020-02-29 [Figure 2-11]  

Early Cut-off : 2020-02-25 [Figure 2-12] 

* NOTE: Have to change the OT cut-off date for next month as well (must be a continuous date 

between month) to avoid any OT records being omitted  

 

 

 

 

  

Figure 2-11 

Figure 2-12 



 
 

Formula 

Define the calculation formula and subject to statutory based on company’s policy. 

Steps to create a Formula: 

1) Define formula group (Allowance/Deduction/Overtime/BIK) 

2) Define calculation formula 

3) Identify Variables (or named as Base Code) that need to be created.  

4) Decide the name of Base Code and Name of the Formula.  

• Note: No spacing for naming. No mathematics symbol ( + - * / ).  

• Replace spacing or mathematics symbol with underscore [ _ ] 

5) Create in system 

 

Example: 

1) Define formula group (Allowance/Deduction/Overtime/BIK) 

Overtime 

2) Define formula calculation 

OT 1.5 = SAL / 26 / 8 * 1.5 * hours 

3) Identify Variable(Base Code) that need to be created 

OT 1.5 = SAL / 26 / 8 * 1.5 * hours 

4) Decide the Base Code name and Formula name 

• Please take note: No spacing & No mathematics symbol ( + - * / ) in naming.  

• Replace spacing or mathematics symbol with underscore [ _ ] 

OT 1.5 = SAL / 26 / 8 * 1.5 * hours 

 

Correct name for the base code and formula  

OT1_5 = SAL / 26 / 8 * 1.5 * UNIT_OT1_5 

 

5) Create in system 

a. Base Code Setup 

b. Formula Code Setup 

c. Payroll View Control 

 

 

 

  



 
 

3.1 Base Code Setup 

3.1.1 Create Base Code [Variable] 

Payroll > Formula > Base Code Setup > New [Figure 3-1]  

 

> Insert Name of Base Code > Select Display Group > Save [Figure 3-2] 

 

 NOTE: Check the availability of the base code before creating a new base code to avoid 

duplicates. 

 

Available Base Code 

Base Code Name Description 

CP38 CP38 

SAL Salary 

UNIT Total Working Day 

UNIT_DOM Day of Month (Current Month) 

UNIT_UPL Unpaid Leave (Days) 

ZAKAT Zakat 

  

Figure 3-1 

Figure 3-2 



 
 

Available Formula 

Formula Name Formula Calculation 

CP38 CP38 

UNIT_Unpaid_leave 
Unpaid_leave 

UNIT_UPL 
SAL/26*UNIT_Unpaid_leave 

ZAKAT ZAKAT 

 

Example: 

Name of Base Code : UNIT_OT1_5 

Display Group  : Overtime 

[Figure 3-3] 

 
 

 

 

  

Figure 3-3 



 
 

3.2 Formula Code Setup 

3.2.1 Create Formula 

Payroll Module > Formula > Formula Code Setup > choose Type > New [Figure 3-4] > Insert Name of 
Formula > Insert Calculation Formula (choose Base Code from the List of Code [Figure 3-6]) > tick 
Subject to which statutory > Save [Figure 3-5] 

 

 

 
[List Code] 

      

Figure 3-4 

Figure 3-5 

Figure 3-6 



 
 

 

Example: 

Types of Transaction : Overtime [Figure 3-7] 

Name of Formula : OT1_5 [Figure 3-7] 

Calculation Formula : SAL / 26 / 8 * 1.5 * UNIT_OT1_5 [Figure 3-7, Figure 3-8, Figure 3-9, Figure 

3-10]  

Subject to  : SOCSO, TAX [Figure 3-11] 

 

      

Figure 3-7 

Figure 3-8 



 
 

 

 

     

 
 

 

  

Figure 3-9 

Figure 3-10 

Figure 3-11 



 
 

3.2.2 Delete Formula 
1. From the list of formula, select the formula you wish to remove from the list, then select 

delete. 

2. While deleting a formula, system will show a confirmation message. Once click “confirm”, 

user will not be able to view the removed formula anymore. 

 

 

 

3. If there is a scenario where relative formula might be calling the main formula that you wish 

to be removed. For instance, users are required to delete the relative formula first. The 

following message below will appear if user is deleting the main formula. 

 

  



 
 

3.2.3 Restore Formula 
1. To restore the deleted formula, user need to select “Restore” and a list of deleted formula 

will be displayed.  

2. Select the formula that you wish to restore and select “Restore Records” to proceed. 

 

3. A confirmation message will be displayed for further clarification. Select “Ok” to proceed. 

 

 

 

4. Once completed, user would be able to make amendments on the restored formula. Once 

finished, click “Save” to compare the restore process. 

 

 

  



 
 

3.3 Payroll View Control 

3.3.1 Payroll View Code / Show Code at Processing Screen 

Payroll > Formula > Payroll View Control > Tick Hide / Show / Exclude > Save [Figure 3-12] 

1. User can go to payroll view control and set 3 types of pay period (Mid, End, Ad-hoc). User 

can choose to show or include the base code in payroll staging.  

2. For example, if user untick SHOW in the checkbox of “BIK_CAR” for month END, 

“BIK_CAR” will not be displayed in month END processing.  

If user untick INCLUDE in checkbox of “BIK_CAR” for month END, “BIK_CAR” will be 

excluded and not calculated in month END processing.  

 

Sample:  

 

 
Untick “Show” in the row of “Month End” under column End,  

Result showed: Info of Month END in the row of “BIK_CAR” will Not Showed 

 

The month end of Refund_Deposit under End will not show  



 
 

3. Drag & drop the sequence of the base code by clicking ‘Change Sequence’.  

4. Sequence of columns on the staging table will be updated based on the sequence applied in 

payroll view control. 

 
 

 

Drag & drop to change the sequence then click save.  

 

Sequence of the staging table will be following the payroll view control. 

  



 
 

5. Besides, user also can view base code that is already set to be Show and Include in the 

payroll loading screen, click the view control located at right bottom of payroll loading 

screen.  

 
6. A pop-up screen will display the base code that already set to be included & set to show. 

Drag and drop to change the sequence of the base code.  

 
 

  



 
 

Allowance and Deduction Scheduling 

Scheduling of fix / ad-hoc allowance / deduction / statutory contribution / BIK for employee. 

4.1 Assign Allowance / Deduction / Statutory Contribution / BIK 

Payroll Module > Assign Allw / Ded > choose Type / Valid Date / Amount / Apply to Employee (tick 
the employee to assign) > Assign [Figure 4-1] 

 

 

  

Figure 4-1 



 
 

Available Assignments: 

✓ Allowance 

✓ Deduction 

✓ Statutory Employer 

• EPF  

Can choose to fill in % OR select Group from the list 

* NOTE: Refer EPF table 

• SOCSO  

Can choose to fill in the Amount OR select Category from the list 

* NOTE: Refer SOCSO table 

• PRS  

Can choose to fill in % OR select Remain amount of EPF employer 

Explanation: 

Remain amount of EPF employer – PRSER will calculate based on the EPFER, 

ensure that you have set % of EPFER and the % must be higher than the statutory 

law.  

Example:  

EPFER  = set 15% 

PRSER = new EPFER (15%) – original EPFER (13%) 

PRSER = 2% 

✓ Statutory Employee 

• EPF 

Can choose to fill in % OR select Group from the list 

* NOTE: Refer EPF table 

• SOCSO 

Can choose to fill in the Amount OR select Category from the list 

* NOTE: Refer SOCSO table 

• PCB 

Fill in the Amount 

* NOTE: System will take the higher amount between the PCB calculator and 

scheduled amount 

Example:  

PCB = set 1000 

If PCB calculator get the tax amount with RM1500, then system will take RM1500 as 

PCB deduction. 

PCB scheduled amount only works effectively when the amount is higher than the 

calculator.  

• PCB to Zakat 

Fill in % 

Explanation: 

System will calculate amount Zakat based on the % from the PCB amount, then 

PCB deduction will be remitted to Zakat. 

Example: 

PCB to Zakat  = fill in 30% 

If PCB  = RM600 

ZAKAT  = 30% of PCB 

= RM180 



 
 

New PCB = RM420 

 

 

 

✓ Employer Contribution (100% of Employee’s Statutory Paid by Employer) 

• PCB 

• SOCSO 

✓ Benefit In Kind 

 

* NOTE: All statutory contribution is based on law, if decides to contribute higher 

amount, user have to do scheduling setting. 

Example 1: 

Allowance  : MEAL_ALLW 

Valid Date  : Effective Start Date 2020-01 

Amount  : 100 

Apply to Employee : Select from the table of employee list > Tick 

Total Employee  : total selected employee  

[Figure 4-2]  

  

Figure 4-2 



 
 

Example 2: 

Allowance  : Employee EPF 

Valid Date  : Effective from 2020-01 

Amount  : 11 % 

Apply to Employee : Insert Employee No. From_ To_ (Starting and Ending of employee no.) > 

Select (Apply filter on the employee no. from start to end) 

   * Only apply to continuous employee no.  

Total Employee  : Total employee selected  

[Figure 4-3] 

  
 

  

Figure 4-3 



 
 

4.2 Detail (Assignment History) 

4.2.1 Filters 

Payroll Module > Assign Allw / Ded > Detail (2nd Tab) [Figure 4-4] 

Explanation: 

 

1. Select a type from drop-down to apply filter 

2. Choose transaction from drop-down to apply filter 

3. Select the effective date 

4. Choose the pay group to apply filter 

5. Insert the starting employee no. and ending employee no. 

6. Retrieve the details based on the input and selections.  

 

Example: 

Type  : select Type, “Statutory (Employee)” 

Transaction : select Transaction from the drop-down list – EPF  

Then click “Retrieve” 

Employee List table will be updated as per the selected Type and Transaction 

[Figure 4-5] 

 

 

 

  

Figure 4-5 

Figure 4-4 



 
 

4.2.2 Edit Assign Allowance/Deduction 

Edit [Figure 4-6] > change Amount/Valid Pay Period (From-To) > Save [Figure 4-7] 

 

 

  

Figure 4-6 

Figure 4-7 



 
 

Tax 
Accumulated income, schedule tax for employee and statutory table. 

5.1 TP3 Form 

5.1.1 Insert TP3 Data 

Payroll > Tax > PCB/TP3 Form > Select Employee No > New [Figure 5-1] > Insert data > Save [Figure 5-
2] 

 

 

 

* NOTE: Employee must set with pay info (Employee Profile – Payment Info)  

Figure 5-1 

Figure 5-2 



 
 

5.1.2 View / Edit Data 

View Payroll > Tax > PCB/TP3 Form > select Employee No – view [Figure 5-3] 

Edit Payroll > Tax > PCB/TP3 Form > select Employee No > Edit > change the data > Save [Figure 

5-3] 

 

 

5.1.3 Delete Salary Data 

View Payroll > Tax > PCB/TP3 Form > select Employee No – view [Figure 5-3] 

Delete Payroll > Tax > PCB/TP3 Form > select Employee No > Delete [Figure 5-3-1]> Confirm too  

Delete > Confirmation [Figure 5-3-2] 

 

 

 

Figure 5-3 

Figure 5-3-1 

Figure 5-3-2 



 
 

5.2 Statutory Setup 

5.2.1 View Table for Statutory 

Payroll > Tax > Statutory Setup > EPF Table / Socso Setup / Tax Deduction > choose Year – screen will 
display table as [Figure 5-4] 

 

* NOTE: Contribution rates of all statutory for both employee and employer will set to 

compatible to law system by default.   

Figure 5-4 



 
 

5.2.2 Tax Relief Setup 

Payroll > Tax > Statutory Setup > Tax Relief Setup > Edit > choose Formula Code > Save [Figure 5-5] 

  

 

5.3 Tax Group Exception 

5.3.1 Assign Tax Group 

Payroll > Tax > Tax Group Exception > choose Tax Group / Apply to Employee (tick √ employee to 
assign) > Assign [Figure 5-6] 

  

Figure 5-5 

Figure 5-6 



 
 

5.3.2 Details (Assignment History) 
5.3.2.1 Filters 

Payroll > Tax > Tax Group Exception > Detail (2nd Tab) [Figure 5-7] 

Explanation:  

 

1. Select the Tax Group to apply filter 

2. Insert the “from” and “to” of employee ID. 

3. Choose pay group to apply filter 

4. Retrieve the details based on the input and selections  

 

Example: 

Tax Group : Local 

Select “Retrieve” 

Employee List table will be updated as per the selected Tax Group 

[Figure 5-8] 

 
 

  

Figure 5-8 

Figure 5-7 



 
 

Process 
Before user proceed with payroll processing, user will have to conduct some checking on employee data 

or updates on the relevant data such as new hire or resign date, increment, fix schedule, date of pay 

period and etc. 

6.1 Payroll Processing 

Payroll > Process > Payroll Processing > select Pay Period > Choose employee to display in staging > 
retrieve the latest one if any data is created in staging > Proceed [Figure 6-1] 

Step to use:  

1. Select pay period. 

2. Click “proceed” 

 

* NOTE: Only pay period with OPEN status will be shown

 

 

3. A pop-up screen will be shown. 

4. User can select certain employees to show in staging. (Employees are All Selected by 

default setting.) 

 

5. After employees is being selected, click proceed. User will see “Retrieve latest” in the table. 

User can now decide to remain or retrieve the latest data of employee. 

6. Click proceed to Payroll Staging table. 

Figure 6-1 



 
 

 

1. If user choose to remain data, data will not be changed or replaced with amendments 

made. 

2. If user choose to retrieve latest, history data will be replaced with new data will be 

retrieve reflect in staging table.  

 

 

 

 

 

 

1. Browse CSV input file from computer and Upload the input file to the payroll system.  



 
 

2. Apply filter on the employee no. (start and end of the employee no.)* Only apply to 

employee no in the certain page 

3. The processing table list. 

4. Page No. on the staging table. 

5. User can choose to show number of employees to be displayed in 1 page. 

6. Click confirm to process 

 

7. Export to excel file (.csv) for data updates and then upload back to system. 

* NOTE: Only selected employee displayed on screen will be processed.  

  



 
 

6.1.1 Export to Excel file and Upload into System 

Payroll > Process > Payroll Processing > Select Pay Period > Proceed > Export to Excel file > Do data 
updates in excel and save > Choose File > Upload > Data checking on table > Click Confirm to process 
on selected employees [Figure 6-2]  

 

 

 

* NOTE: Excel file must save as CSV format 

 

 

 

 

 

 

 

 

 

Figure 6-2 



 
 

6.1.2 Steps to use payroll staging table. 

1. After choosing pay period, user can also select job class or department for processing. 

 
 

2. Staging table will display employees based on the chosen department.  

 

  



 
 

3. Modified data will be saved in staging table.  Screenshot below shows the original value will 

still be kept in system after modification and logged off. 

 

Before modifying the data (the original data):  

 
 

After data is modified: 

  



 
 

4. Even after data is being modified, user can reset the data back to the original value, by 

selecting which employee to reset. (Note: all employee in staging table will be reset if no 

employee is selected). Sample as below:  

 
3 employees are checked and click reset; the amount will be reset to the original one (refer 

to screenshot above).   

 
The data of checked employee will be reset. 

  



 
 

 

5. When user open the staging table, user can lock the staging table to prevent other users 

from amending the data on the staging table. (Note: If 2 users conducting data edit on 

staging table at the same time, it might cause data loss due to error.) 

 
If user happen to select the same department while another user is editing the data, system 

will automatically disable the checkbox on that department. 

 

6. However, user can choose to take over the access control by clicking “Unlock”. 

 
To unlock staging table of the selected department. 

 

7. A table will be displayed, user can select any department to unlock. 

 

Fox example, 4 departments are selected to unlock. 



 
 

 

Insert password and unlock the department. 

 

(Note)User can set password in control setup. 

 

The department is now enabled.

 

Choose department to proceed. 

(Note: only selected department and job class will be displayed in staging table) 

 

8. After the user has took over the control access of that departments, the original user will no 

longer be able to edit the data.  



 
 

 
A warning message will be showing that another user has took over the control access right 

to edit the data. 

9. Before user leaving the staging table, user will have to click Save & Release to release the 
staging table to other admins to edit the table. If the user does not release the staging 
table, other user will have to unlock the department in order to amend the data by taking 
over the access control (shown as above). 

 

 

 

 

 

 

 

 

 

 

 



 
 

10. A table will pop-up if system detects that the selected employees have missing of 

information like Date of Birth (D.O.B) in their employee profile as D.O.B has become a 

mandatory field to ensure statutory calculation accuracy.  

 
 

  



 
 

6.2 Payroll Log 

Payroll > Process > Payroll Processing > Log Report (2nd Tab) > Select Load Date > Select Log ID > 
Select Employee > Select Process (Formula/PCB) > Retrieve [Figure 6-7]  

Explanation:  

 

 

1. Load Date – date of payroll processing 

2. Lod ID   – number for iterative process 

3. Employee  – employee ID and name 

4. Process  – optional 

[Process Formula] means to show computation of salary portion only 

[Process PCB] means to show the computation of PCB only 

[-] means show all, include Formula and PCB  

Figure 6-7 



 
 

6.3 Employee Payment Status 
Step to use:  

1. Payroll Module > Process > Payroll Processing 
2. Select Pay Period 
3. Click “Update employee payment status” 

 

 

 
 

4. A table showing employee payment status will be displayed. 

5. A toggle button allows user to update status of payment. 

6. If status shows “paid”, the employee will be excluded from staging table. 

7. If status shows “pending”, the employee will still be included on the staging table.  

  



 
 

Payroll report has a separate section to show the total amount of “paid” employees. User 

able to check the amount paid out referring to the payroll report. 

Step to use:  

1. Payroll > Report > Payroll Report 

2. Select pay period. 

3. Click “Preview 

4. A separated section showing employees with “Paid” status will be displayed. 

 

 

  

  



 
 

6.4 On-hold Salary & flagged as No pay feature 
On-hold salary 

The latest feature allows user to be able to flag employee salary’s status to on-hold via payroll load 

while conducting payroll processing.  

(The previous feature will need user to do updates in Employee Profile Module)  

Steps to use:  

1. Select Pay Period 
2. Click “Update On-Hold Salary” 
 

 
 
3. A table will be displayed as below.  

4. User can set specific date to on hold the salary of individual employee. The selected 

date will be reflected automatically in Employee Profile module.  

  



 
 

Flagged as No Pay 

No Pay Flag via Payroll load. Employee being flagged as No Pay will be permanently excluded from 

payroll staging table.  

Step to use:  

1. Select pay period. 

2. Click “Update On-Hold Salary”. 

 

3. A table will be displayed as below.  

4. In the table, user can flag status to No Pay to exclude employee from payroll processing.  

 

 

 

  



 
 

6.5  Based on Actual Wages to calculate EPF Contribution 
 

Instead of following the EPF Reference Table, system is configurable to calculate amount of EPF 

Contribution for both employee and employer by using total actual wages.  

(Note: User can enable this feature via Control Master (Admin). 

Step to use: 

1. Browse Control Master (Admin). Search and select “EPF Actual Wages Calculation” from 

the dropdown. 

 

2. A table will be displayed as shown below. By default setting, system will turn OFF the 

feature in the column of Map Field. To activate this feature, user will have to change the 

figure in the map field from “O” to “1”.  

“0” means to disable the feature.  

  



 
 

Result: 

1. The following screenshot shows differences of the EPF amount (Employer & Employee) 

when “EPF Actual Wages Calculation” is activated and deactivated.     

EPF Actual Wages Calculation: Activated, set as “1”  

  

EPF Actual Wages Calculation: Disabled, set as “0” 

   



 
 

6.6  Employment Insurance Scheme (EIS)  
Effective from year 2018, Employment Insurance Scheme (EIS) has becomes one of the mandatory 

contributions for both employee and employer at the rate of 0.2% of total wages.  

If employee choose to be excluded from contribution, user may set “0” to EIS in the “Assign Allowance 

and Deduction”. 

Step to use: 

1. Assign EIS to formula 

I. Identify which formula code subjected to EIS. To assign to formula, select the formula in 

the dropdown of “Select Formula”, click “Edit” to make changes. Tick “EIS” in “Subject to” 

then save the changes made.  

 

2. Repeat the same process in the Payroll Processing (you may refer to section 6.1).  

3. Once payroll is processed, EIS contribution will reflected in payroll report. 

4. User can check the EIS calculation in the report of “Payroll Calculation” or “Statutory”.  

Sample of report as below: 

 

 

 

 

 



 
 

I. Payroll Calculation Report 

 

II. Statutory Report 

 

 

  



 
 

5. EIS Contribution Exemption (for non-mandatory group (aged below 18 and above 60) 

I. To be exempted/excluded from EIS contribution, user need to make the settings via 

“Assign Alw/Ded” page. All employees aged below 18 or above 60 will be exempted by 

default. However, if employees from this age range would like to contribute EIS, user may 

assign help the individual employee to contribute EIS. To do this,  

Select EIS under “Statutory (Employee Contributions)” dropdown.  

Assign employee to “Follow EIS Contribution Table” in the feature of “Assign Allw/Ded”.   

Example 

1. Select EIS from the “Statutory (Employee contribution)”. Set amount to “0” and 

insert the valid date. This action will exclude employees from EIS Contributions based 

on the configured pay period.  

 

 

2. Lastly, select which employee to be excluded/ exempted from the table and then 

“Save”. 

 
 

  

 

 



 
 

Report 
Retrieve > Verify report and view > Approve report and payslip. 

7.1 Payroll Report 

7.1.1 View Payroll Report 

Payroll Module > Report > Payroll Report > Select Pay Period > Tick Types of Pay Period > Preview 
(refer to screen) / Export (export to Excel format) [Figure 7-1] 

* Tick all the boxes in types of Pay Period to combine all details one report.  

 

Sample Report: 

 

  

Figure 7-1 



 
 

7.1.2 Confirm Processing or Re-Open for Processing 
Payroll Module > Report > Payroll Report > Select the Pay Period > Check status of report > Select 
Confirm Processing / Re-open for Processing > Click OK for confirmation [Figure 7-2] 

 

Confirm Processing: Pay Period will be closed and not be able to process.  

Re-Open for Processing – Pay Period will be re-open and ready to reprocess.  

 

7.1.3 Delete Payslip 
Payroll Module > Report > Payroll Report > Delete Payslip Screen [Figure 7-3] > choose Pay Period and 
Period Type > choose Delete Mode > Proceed [Figure 7-4] 

 
By Pay Period – Delete all payslip based on pay period 

By Department – Delete payslip based on selected department 

By Employee – Delete payslip based on selected employee 

 

  

Figure 7-3 

Figure 7-4 

Figure 7-2 



 
 

 

7.1.3.1 View Payslip Status 

E-Pay Module > E Pay Slip Administration > Pay Slip (Admin) > choose Pay Period > Retrieve [Figure 7-
5]  

 

 
 

7.1.3.2 Approve Payslip 

E-Pay Module > E Pay Slip Administration > Pay Slip (Admin) > E Payslip Summary > choose Pay 
Period and check the status > Approve [Figure 7-6]  

 

 

7.1.3.3 3-Ply Printing Format  
For companies using 3-Ply payslip, system administrator is able to make adjustment on the layout 

format of the 3-ply payslip for printing purposes. Go to Control Profile (Admin) and select “3-Ply 

Printing Format” from the drop-down in Type of Control Setup. 

Figure 7-6 

Figure 7-5 



 
 

 

 

  



 
 

No. 3-Ply Print Format Explanation 

1 Printing of company name To display company name in 3-Ply pay slip 
Group position: 0 – Disable, 1 - Enable 
(Default: 0) 

2 Max pay slip per page To display multiple pay slips in one page 
Group position: Any desired number   
(Default: 1) 

3 Number of lines to move to the 
hidden area per pay slip 

To Insert lines between body and header of payslip 
Group position: Any desired number  
(Default: 3) 

4 Number of lines to insert  
between pay slip 

To insert lines between pay slip 
Group position: Any desired number 
(Default: 54) 

5 Max line per pay slip To set the maximum line for each pay slip. 
Group position: Any desired number 
(Default: 65) 

6 The height of each pay slip in 
pixel 

To edit the height for each pay slip in pixel. 1 cm = 37.79 px. 
Group position : Any desired number 
(Default: 665) 

7 Number of lines to skip to the 
top of the pay slip 

To set number of lines difference in between the very top of 
the pay slip and the header. 
Group position : Any desired number 
(Default : 0) 

 

  



 
 

7.2 Payroll Submission Report (Manual Form)  

Payroll > Report > Payroll Report > Submission Report > Select Pay Period > Select Report Type > 
Retrieve  

[Figure 7-8] 

 
 

 

 
[Figure 7-9] 

1. Information to be printed in the form 

2. Cheque number 

  

Figure 7-9 

Figure 7-8 



 
 

Available Report Type 

Report Module Report Type Description 

EPF EPF Borang A Monthly Contribution 

Borang BBCD Monthly Contribution (CD/Diskette) 

SOCSO Perkeso Borang 8A Monthly Contribution 

Perkeso Lampiran A Monthly Contribution (CD/Diskette) 

Borang Pendaftaran Pekerja Registration for additional employee 

Borang Pemberhentian Pekerjaan Employment Termination Form 

Income Tax CP39 Monthly tax deduction from salary 

CP39-A Tax deduction from arrears for Last Year 

salary/allowance 

Borang CP21 Notification by employer on employee’s departure 

from Malaysia 

Borang CP22A Notification of Cessation of An Employment 

(Private) 

Borang E Employer’s/Company’s particular 

CP8D Summary report/details for workers earning 

Tabung Haji Tabung Haji Monthly contribution 

Tabung Haji (Excel) Monthly contribution (Excel Format) 

ASB ASB Monthly contribution (CD/Diskette) 

Zakat ZAKAT Monthly contribution 

Borang Bayaran Skim Berkat Monthly contribution 

PTPTN PTPTN Monthly payment 

  



 
 

7.3 Payroll Report Setup 

7.3.1 Transaction Type Setup 

Set types of transaction (to display the types of formula/transaction on the balance sheet of report)  

Payroll > Report > Payroll Report Setup > Assign Transaction Type (Allowance/Deduction/Overtime) > 
Save [Figure 7-10] 

 
 

7.3.2 New Type of Report Setup 

Add a new sheet in report 

Payroll > Report > Payroll Report Setup > Type Setup > Insert Transaction Type > (if necessary) Mark √ 
to Sum up to Gross Pay > Add > Return to 1st tab of the Transaction Type Setup > Assign the 
Transaction to the New Transaction Type [Figure 7-11] 

 
Explanation: 

Transaction Type Name : Naming of the New Sheet in the Report 

Sum to Gross Pay : Once Mark √, the amount will be added to Gross Pay, transaction will be 

shown 

before Gross Pay 

No √ – amount is not added to Gross Pay, transaction will be shows after GrossPay 

Sequence  : Sequence of transactions in Payroll Report (Payroll Calculation sheet) 

  Not select any sequence – system will arrange randomly 

If Select sequence – system will follow the sequence set to display 

additional transactions in Payroll Calculation sheet.  

 

Example: 

Transaction Type (Naming of Balance Sheet) : Claims Reimbursement 

Figure 7-10 

Figure 7-11 



 
 

Sum to Gross Pay    : Tick √ for amount added to Gross Pay 

Sequence     : Not assign (let system arrange randomly)  

[Figure 7-12 & Figure 7-13] 

 

 

 

 

 

 

  

Figure 7-13 

Figure 7-12 



 
 

Text File Generator 
Banking payment file (apply to payroll report that already been confirmed / approved, able to 

generate text file for payment purposes).  

8.1 Generate Text File for Payroll and Statutory Payment 

Payroll > Report > Text File Generator > Choose Pay Period > Choose types of Text File > Generate 
[Figure 8-1] 

 

Sample Text File: 

 

Generated Text file filters out Employee with “Paid” Status.  

Step to use:  

1. Payroll Module > Report > Text File Generator 

2. Select Pay Period. 

3. Select one type of Text File. 

4. Employee with “Paid” status will be listed in a separated column, will not shown 

in the generated text file.  

5. Click ‘Generate’ button 

6. If you wish to retrieve list of employees at “Paid” status in the text file, [tick √] 

the employee in the “Paid employee” column and click “Generate”. 

Figure 8-1 



 
 

  



 
 

Payroll EA Load 
Preparation of Year-end EA for submission purpose. 

9.1 EA Setup 

Payroll Module > Process > Payroll EA Load > EA Setup > Edit > Tick √ to Assign > Save [Figure 9-1]  

 
 

Example:  

 

 

 

 

 

Figure 9-1 



 
 

9.1.1 EA Load 
9.1.2 Export EA Data to Excel format (for verification purposes) 

Payroll > Process > EA Load > Select Year of EA > Download EA Template [Figure 9-2] 

 

Example: 

EA Template 

 
 

9.1.3 Payroll EA Process 
EA Process allow user to process employee EA Form without download and upload the excel file. 

 

 

Figure 9-2 



 
 

Employee Salary Analysis (A File generated by user for checking & verification purposes) 

E-Pay > E- Pay Slip Administration > Pay Slip (Admin) > Employee Salary Analysis > Choose Column By 
- Transaction / Sort By - Employee / Sub Total - Employee / Filter (by Pay Period – choose only year 
2019, Transaction - All, Employee - All) > Preview / Export [Figure 9-3]  

 

Example: 

Employee Salary Analysis File 

 

 

 

Steps to conduct checking (user may refer below example as reference): 

1) User can conduct checking in EA Setup with transactions in groups/categories (Refer to 9.1 

EA Setup) 

2) Add all the amount of transaction under the same group/category (Refer to 9.1 EA Setup) in 

Employee Salary Analysis File 

3) Compare the total accumulated amount with the EA Template  

Figure 9-3 



 
 

Example 1:  

Employee No 2000014 (by Individual)  

1) Conduct checking in EA Setup, which displays transactions in groups (Refer to 9.1 EA 

Setup) 

 

2) Add amount of all transactions in the same group (Refer to 9.1 EA Setup) at Employee 

Salary Analysis File 

Employee Salary Analysis File (Part 1)  

 

REGULAR =27300  Overtime1_5 = 59.62   Absent = -596.15 

TOTAL = 26763.47 

 

3) Compare all amount added with the EA Template 

EA Template 

 
 

 

 

 

 

 

 

 

 

 



 
 

Example 2:  

All Employees  

1) Conduct checking in EA Setup which transaction displayed in groups (Refer to 9.1 EA 

Setup) 

 

2) Add amount of all transactions on the same group (Refer to 9.1 EA Setup) at Employee 

Salary Analysis File 

Employee Salary Analysis File (Part 2)  

 

REGULAR = 330600.00 

Overtime1_5 = 59.62 

Overtime2_0 = 2456.72 

absent  = -1634.62 

Unpaid_leave    = -859.67 

TOTAL  = 330622.05 

3) Compare the amount added with the EA Template (as below) 

EA Template 

 

 

* NOTE: REPEAT THE SAME STEPS FOR ALL TRANSACTIONS FOR ALL EMPLOYEE 



 
 

9.2.2 Upload EA Data 

Payroll Module > Process > EA Load > Choose EA Year > Choose File > Upload > Check the form in EA 
Form (Admin) [Figure 9-4] 

 

 

9.2.2.1 View EA Form 

E-Pay > EA Form Administration > EA Form (Admin) > Choose Employee No > Choose Tax Year > 
Retrieve [Figure 9-5]  

 

  

Figure 9-4 

Figure 9-5 



 
 

9.2.2.2 Approve EA Form 

E-Pay > EA Form Administration > EA Form (Admin) > EA Summary > Choose Tax Year and check the 
status > Approve [Figure 9-6]  

 

 

9.3 EA Form Setup – Insert EA’s Officer Information 

Company Benefit Setup > Control Master (Admin) > EA Form Setup > Insert officer’s details > Save > 
Once saved, details of officer will be displayed as below [Figure 9-7]  

 

Figure 9-7 

Figure 9-6 



 
 

TP1 Form (Admin) 
Rebates and reliefs such as technology purchases, medical expenses, insurance and book purchases 

to adjust MTD amount. 

10.1 Create New TP1 Form 

TP1 Form (Admin) > Select Employee and Tax Year > New > Fill Amount > Save [Figure 10-1]  

 
  

Figure 10-1 



 
 

10.2 Edit TP1 Form 

 TP1 Form (Admin) > Select Employee and Tax Year > Edit [Figure 10-2.1] > Replace Amount needed > 
Save [Figure 10-2.2]  

 

  

 

 

 

  

Figure 10-2.1 

Figure 10-2.2 



 
 

10.3 Delete TP1 Form 

 TP1 Form (Admin) > Select Employee and Tax Year > Delete [Figure 10-3.1] > Confirm Deletion 

 [Figure 10-3.2]  

 

 

 

  

Figure 10-3.1 

Figure 10-3.2 



 
 

FAQ 

1. How to search the pay period to do payroll processing? 

Firstly, check the status of the pay period in the Pay Period Maintenance 

Payroll > Policy > Payroll Period Maintenance > Edit > Click on Inactive – If the message 
shows OPEN means the Pay Period is ready to do payroll processing > Save 

Page 8 for status of pay period (Open for processing)  

2. What should I do if I mistakenly processed payroll on current month for an employee who 

had already resigned last month? As there will be no pay-out for this month.  

Firstly, delete salary data of the resigned staff 

Payroll > Report > Payroll Report > Delete Payslip on Screen > Choose Pay Period and Pay 
Period Type > Select Delete Mode by individual Employee > tick √ the employee > Proceed 

Page 30 to delete salary data  

3. How to search for transaction code in the processing page that I have created? 

Firstly, check whether the base code is created and shown in system.  

Payroll > Formula > Payroll View Control > tick √ to Show > Save 

Page 12 for Base Code Setup.  

4. What should I do if found missing of Allowance Transaction after payroll is processed? 

Firstly, set transaction type (to display the details in the balance sheet of the report) 

Payroll > Report > Payroll Report Setup > Assign Transaction Type – 
Allowance/Deduction/Overtime 

Page 62 – Transaction Type Setup 

5. How to process Ad-Hoc Bonus which separated from monthly payroll? 

Firstly, user has to create ad-hoc pay period for Bonus pay-out 

Payroll > Policy > Pay Period Maintenance > Create > choose Year of Bonus, Month of Bonus, 
Pay Policy, tick Ad-Hoc and set the name pay period “Bonus” without spacing > Generate 

Page 5 to create ad-hoc pay period. 

6. How to amend payroll cut-off date for selected month only?  

Payroll > Policy > Pay Period Maintenance > Edit > Change the Date > Save 

Page 6 on defining cut-off date 

7. How can I change information in the text file, for example information of contact person?  

Company Benefit Setup > Control Master (Admin) > Payroll Setup > Insert new information > 
Save 

Page 5 to verify/update info such as contact person, contact number, bank information, and 

company’s statutory number and etc. 



 
 

8. What should I do if I cannot generate text file for salary or statutory? 

Firstly, user has to check the status of payroll report to see if it’s confirmed.  

Payroll Module > Report > Payroll Report > select the Pay Period > check status of report > 
Click Confirm Processing > click OK for confirmation 

Payroll Report needs to show Confirmed status before generating text file.   

Page 56 Payroll Report Verification 

9. What should I do if the total amount of bank listing on the payroll report different from the 

amount reflected on text file?  

First, user must check all the status of all types of transactions, if found one of the 
transaction types is missing, user have to set transaction type (to reflect on the balance sheet 
of payroll report).  

Payroll > Report > Payroll Report Setup > assign Transaction Type 
(Allowance/Deduction/Overtime) 

Page 62 for Setting up transaction type.  

10. What should I do if found some mistakes on staff’s income tax (higher than estimated)?  

Clarify whether employee is Malaysian?  

Yes. Refer to (A) 

No. Refer to (B) 

(A) Please check column of IC No. reflected on payroll input file.  

If IC number inserted in system is incorrect, amend and reprocess. 

If input file does not display column of IC number, please check data in Employee Profile 
Module (IC number and Nationality), amend the data and reprocess the payroll. 

 

(B) Expatriate has already staying in Malaysia for at least 182 days. 

If yes, user has to determine if the tax rate following local rate? If yes, user have to set the 
tax rate in system for the employee 

Payroll > Tax > Tax Group Exception > Select Tax Group / Apply to Employee (tick √ to assign 
to employee) > Assign (Refer Page 32 to assign Tax Group) 

If the stay is less than 182 days, the tax rate will be 28%. 

11. What should I do if employees unable to view their pay slips? 

Check status of pay slip & approve the pay slip  

E-Pay Module > E Pay Slip Administration > Pay Slip (Admin) > E Payslip Summary > Select 
Pay Period and Check the status > Approve 

Page 58 to view status and approve pay slip.  

 

 



 
 

12. What should I do if my employees wish to retain EPF contribution at 11%? 

Firstly, to set EPF’s contribution percentage (%) 

Payroll Module > Assign Allw / Ded > Select EPF in Statutory Employee / Valid Date-Effective 
date / Amount-11% / Apply to Employee (tick √ to assign) > Assign 

Page 23-24 to assign Deduction  

13. Why Employee ID turns into become 1 digit after being exported to excel file? It should be 3 

digit, for example, from 005 becomes 5. 

It might cause by the format of Microsoft Excel. The potential issues that might occur when 
using excel format: 

a. Employee number 

Highlight Column of Employee ID > Right click > Select Format Cells > Select Number > 

Select Custom > Type 3 zeros (3 digits, auto fill zero in front) > OK 

 
b. IC number 

Ensure the IC number is in a correct format before you save the file. If the IC number 

shows 9.00801E+11 then have to re-format the cell before saving the file. To do so,  

Highlight IC number column > right click > choose format cells > Number > Number > 

Decimal places choose 0 (zero) > OK 

Verify the IC number, make sure are all correct and save. 

OR 

Delete the IC number column. 



 
 

 

c. Hire / resign date 

Ensure that the format for date in the column is correct before save. The format must 

be YYYY-MM-DD (Y-Year, M-Month, D-Day). 

Highlight date column > right click > Select format cells > Select Number > Select 

Date >Select location – English (Malaysia) > choose YYYY-MM-DD > OK 

OR 

Delete the date column. 

 

  



 
 

14. How to print the payroll report? 

Export report to excel format > File > Print > Change the setting to Landscape Orientation, A4 
size, Narrow Margin, and Fit All Column on One Page > Print 

 

  



 
 

15. How to print the Payroll Report with title can be reflected on each page?  

Export report to excel format > Page Layout > Print Titles > Sheet > Select Rows to report at 
top > Ok > File > Print > change the setting to Landscape Orientation, A4 size, Narrow 
Margin, and Fit All Column on One Page > Print 

 

 


